Unable to Download gem with native extensions with Ruby 1.8.7 and Rails 3.0

A couple of days back I have installed Ruby 1.8.7 for working with Rails3.0.0 To my surprise whenever I was executing the any of the gem installation commands with native extensions, it was failing. Then I found the following stuff after searching quite a bit.
Following URL gives the details or else you can look at the bullet-ed points below and execute them in order

1) Uninstall any DevKit previously installed in your system. Control Panel\All Control Panel Items\Programs and Features --> uninstall Devkit
2) Get the DevKit from the following url http://rubyinstaller.org/downloads/
3) Download the exe file to a local folder like D:/DevKit
4) Go inside the folder from the command prompt and execute the following commands
i) ruby dk.rb init --> this will create the config.yml file
ii) ruby dk.rb install
iii) devkitvars.bat  --->; This will add in the PATH variable
5) Install the gems
gem install devise --platform=ruby
gem install devise_rpx_connectable --platform=ruby
6) or you can add them in the Gemfile of your rails3 app and just execute
bundle

The above command will then install the gem with the native extensions. Remember to add the platform part.
Post a Comment

Popular posts from this blog

Loved this campaign by Vicks India

Uninitialized constant Win32 (NameError)-cucumber