Posts

Showing posts from November, 2011

VMware+ubuntu with Ruby on Rails

Image
Lately I have started using VMware with ubuntu on my Windows machine for faster and hassle free Ruby on Rails development. But nothing comes easy, there are pretty many things you need to take care of for this setup. You can follow the steps here, preferably sequentially for the installation. To install rvm, best option is to follow the latest instructions in the rvm site.
And I would love to add the things which I have faced while installation, setup and while running my RoR app here :)
wired connection error, unable to connect to INTERNET from the Virtual Machine. Mainly this is caused not only due to your internet connection/ speed but by a corrupted Virtual machine. refer here for detail. ERROR: Error running '/usr/bin/make install', please read /usr/share/ruby-rvm/log/zlib/make.install.log. This is mainly caused as you are not executing the commands from the administrator mode. In order to do that, instead of doing $ rvm pkg install zlib do $sudo rvm package install zlib.

wired connection error in Vmware

I am recently using VMware with ubuntu for my Ruby on Rails developmental purposes for it's faster. But lately I have faced a weird error after all the initial installations went fine. Whenever I was trying to connect to internet it was failing.
I tries to trouble shoot a lot, ping-ing my host server, fixing the ip related files, reloading the VM updates, running the vm-config-ip tools and many other things from the online forums.
Alas!! nothing worked.

Then I re-installed the Vm-ware and created a new virtual machine and realised re-installation was not required.


Whenever you face such an issue, try creating a new virtual machine.

You can delete the older one, as it takes a lot of space is you are using the softwares related to ruby0rvm, git, packages, gems and IDE, etc. All the virtual machines sre stored under the /Documents/ folder by default. You can just go ther and simple shift+delete the folder from there, which you are not using.

Check the new virtual machine IP connectio…

rbx-require-relative (0.0.5) failure issue

Installing rbx-require-relative (0.0.5) Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/ bundler/issues so that we can fix it. Thanks!/Users/sjain/.rvm/rubies/ruby-1.9.2-p290/ lib/ruby/site_ruby/1.9.1/rubygems/ installer.rb:364:in `ensure_required_ruby_version_met': rbx-require-relative requires Ruby version ~> 1.8.7. (Gem::InstallError) This happens because when we are adding  a dependency on ruby-debug gem in your Gemfile. gem 'ruby-debug' With ruby 1.9, you need to update this with new gem name ruby-debug19. gem 'ruby-debug19' This will eliminate the dependency on rbx-require-relative and fix the issue.