Posts

Showing posts from April, 2014

Inability to bundle install due to certificate error

ERROR: cannot verify rubygems.orgs certificate, issued by a/C=US/O=GeoTrust, Inc./CN=RapidSSL CA.Unable to locally verify the issuers authority.

[LINUX_SERVER]# openssl s_client -host rubygems.org -port 443 socket: Connection refused connect:errno=111
-à Here ideally the certificate should be visible.
[LINUX_SERVER]# ruby -ropenssl -e 'p OpenSSL::OPENSSL_VERSION' "OpenSSL 1.0.0 29 Mar 2010"

Following are the commands to install/update openssl: 1.rvm pkg install openssl 2.rvm reinstall all —force —with-openssl-dir=$rvm_path/usr
This usually occurs if you are behind a firewall
export http_proxy=à will allow the installation behind a firewall.
For the openssl hearbleed issues, can google out and go through the various security patches. Posting fe below:
1.http://lifehacker.com/what-the-heartbleed-security-bug-means-for-you-1560801201 2. http://www.hak9.com/fix-heart-bleed-bug-centos-ubuntu/

Installing Ruby in Linux behind a firewall or where you don't root access

Ok, so the topic can be found very easy! But how will you be installing in a linux box, in which you don’t have root/admin access, and/or ports are blocked by firewall.
Install WinScpConnect to the linux boxTransfer the .gem files downloaded from gem repository, to the linux box

[doel@MY_LINUX_SERVER~]$ gem install rails --local /home/doel/rails-4.0.2.gem ERROR:  While executing gem ... (Gem::DependencyError) Unable to resolve dependencies: sprockets-rails requires sprockets (~> 2.8);railties requires thor (< 2.0, >= 0.18.1); actionmailer requires mail (~> 2.5.4); activerecord requires arel (~> 4.0.0), activerecord-deprecated_finders (~> 1.0.2); activemodel requires builder (~> 3.1.0); actionpack requires builder (~> 3.1.0), rack-test (~> 0.6.2), erubis (~> 2.7.0); activesupport requires i18n (>=0.6.4, ~> 0.6), multi_json (~> 1.3), tzinfo (~> 0.3.37), thread_safe (~> 0.1)
In order to install all the dependencies, you need to install all the gem …